Jump to content

Post your MA pics here!


Recommended Posts

  • 1 month later...
  • 3 months later...

This is my, work in progress. It's 92' 18MA that I bought used in 2000. For 17 years I used and abused her and she never complained but it was finally time. It had a yama 130 (that was a great motor) that I replaced about 1 year ago. new trailer, motor, fuel tank, electronics, gauges, steering, tabs, JP, Ulterra, batteries, pumps and misc in the past year or so. She's get n there.

I don't chime in much but I really appreciate the help and advise when I need it. Thanks to all.

IMG_2534.jpg

IMG_0408.JPG

IMG_0382.JPG

IMG_0381.JPG

  • Like 4
Link to comment
Share on other sites

  • 2 months later...
6 hours ago, Ejerome09 said:

02 with an 02 yamil

Hey, can you check your stringers and see if they connect to the transom?  the 2000 models dont, the 2003 models do, trying to figure out what year they changed it.  My stringer issue may be related to that configuration (or may not) but either way, it will help!  Check my stringer thread in the general forum for more context.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...