Jump to content
Sign in to follow this  
Shallowminded6

Seastar helm clicking

Recommended Posts

Mine was doing the same after my mechanic added fluid. Had to bleed 5 times in three days with a power bleeder. After each bleed he let it sit for a day and it sort of bled itself. Know it has been fine for 5 month approx. have two stations. Part of the problem, was the bleeder hose that I asked him to check out. Was not sealing good.

  • Thanks 1

Share this post


Link to post
Share on other sites
On ‎3‎/‎20‎/‎2020 at 1:56 PM, Shallowminded6 said:

My seastar helm is clicking while turning right. Tried bleeding it. No avail. Any ideas as to what could be causing it?

 

92E6B179-C982-45BF-84C2-A04133A825BF.MOV 13.93 MB · 2 downloads

Does the motor swivel as usual when you turn the steering wheel? Or, are you getting sporadic movement from the motor when you turn the wheel? 

Share this post


Link to post
Share on other sites
21 hours ago, jh141 said:

Did you figure  out what was wrong or find a fix?

Found a fix, bought a new one haha. The boat was getting the motor hung at a shop 2hrs away from me, so I couldnt be there to work on it. Have the old one still, gna either fix and sell or sell discounted to someone that wants to fix it. It made the clicking noise for a long time(3-4yrs) and never had any issues working. Just never that loud. 

Share this post


Link to post
Share on other sites
3 minutes ago, Shallowminded6 said:

Found a fix, bought a new one haha. The boat was getting the motor hung at a shop 2hrs away from me, so I couldnt be there to work on it. Have the old one still, gna either fix and sell or sell discounted to someone that wants to fix it. It made the clicking noise for a long time(3-4yrs) and never had any issues working. Just never that loud. 

Good decision....I had a helm issue on my Pathy that I kept putting off...same thing, click click click....almost laid it up on an oysterbar in a sharp turn in Chokoloskee one afternoon on the way home....errrrr....turn right ? nothing happens?  slam on the breaks?  Yep, almost, glad I was going slow as I normally do in the bars.....next day, bought a new one, self installed, took about 2 hours, lots of bads words said, cracked knuckles and bleeding fingers and a few adult beverages afterwards.

DC

 

  • Like 1
  • Haha 1

Share this post


Link to post
Share on other sites

I had some issues a few years ago.  Heard a few small pops then a loud one which resulted in loss of steering.
In a last ditch effort I took it apart, cleaned it, and replaced the dry rotted o ring at the fill cap that allowed some water to enter.  Been working flawlessly for the last 3 years.  I followed this thread process

https://www.thehulltruth.com/sportfishing-charters-forum/116181-teleflex-steering.html#b

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...