Jump to content
Sign in to follow this  
MA92

Water Temp, Gone!

Recommended Posts

Last week I did the latest update (18.3) to my Simrad Evo 2. Prior to this update, I've had water temp on my echo page, since the unit was new in 2016.  The Simrad unit, and transducer were new with the Pathfinder, which has low hours. I've done all the other Simrad updates w/o problems.

Water temp is now gone from all pages. The Simrad B175, thru hull transducer, is no where to be found in the settings, Echo, etc.

Two calls to Simrad, 1st call with a less than helpful, and sarcastic Tech! Called back today, spoke to more civil Tech, they both told me the transducer is bad. This is after typing the problem into a keyboard while you wait?

I ran the boat last week, one day after the update. Other than no water tamp, the transducer worked perfectly. 

Called the dealer, five counties away, they said to bring to boat in. Called Master Repair, spoke to a guy in service, they said no issues, he knew of, with water temp and Simrad updates.

Anyone had this issue?

 

Share this post


Link to post
Share on other sites

When I update my HDS12, sometimes things disappear.  I suggest you find a buddy with a similar unit to confirm your issue.

Like you found out,  the factory tech department aren't always on their game!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×