Jump to content
Sign in to follow this  
Esteban

16 Redfisher w/Garmin depthfinder problems

Recommended Posts

I've got a 2015 Redfisher 16 that has a Garmin GPSmap 741xs depthfinder (came with the boat - I'm the second owner) that I'm having problems with.  I posted about this problem almost a year ago and thought I had fixed it with a software upgrade.  Basically it stops reading the depth for no apparent reason and just flashes the last number it got stuck on.  This generally happens in fairly shallow water, but it's not consistent on the depth it stops reading, and a subsequent re-boot might or might not get it working again.  At some point it will start working again, as before with no apparent reason, so there's no consistency to the stops and starts.

The solutions I got earlier were to re-boot it, turn it to sonar only (versus combination of sonar and map), and update the software, all of which I have done.  However, although it seemed to initially get better the problem still persists and I can't seem to find a fix.  So, I'm at the point where I'd like to just replace the dang thing with something maybe simpler with fewer features as the current one has things on it I'll never use or need.  So my question to anyone out there is, does Garmin make another depthfinder that will the same transducer and connections or am I destined to replace the entire thing?  Thanks.

Share this post


Link to post
Share on other sites

Not much help.....I have noticed my 741Xs sonar does the same thing. I don't use the bottom machine much as I am shallow water inshore all the time. But from time to time I notice my depth numbers flashing on the icon in the corner of the screen.  Mine is a 2014 18RF so I am assuming that the Garmin unit is from the same model year. My 277 Cobia has a Garmin 7610 and a tru hull transducer. Only time I noticed it flash, is when it runs in aeriated water, either propwash from another boat, or if I am backing down. Then it is interrupted.

Your solution is the same as mine.....turn it off and let it reboot. Sorry wish I was more help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...