Jump to content
mblanar33

Advice on Re-Installing Poling Platfrom - 98 18' MA

Recommended Posts

Looking for some help/advice on reinstalling the poling platform on an 18 Maverick Master Angler. I believe the original install method was lag bolted into the transom. The original lag bolts have obviously been removed so I'm wondering if there is still enough "meat" there for another install. Also, I would much rather have a through bolted connection but I know clearances to work are an issue in this area. I was thinking I could make a backing plate out of 1/8" galvanized plate and weld lock nuts onto this plate so essentially the through bolting process would be easier. 

 

Any input is greatly appreciated. Thanks! 

Share this post


Link to post
Share on other sites
On 9/16/2017 at 11:24 AM, mblanar33 said:

Looking for some help/advice on reinstalling the poling platform on an 18 Maverick Master Angler. I believe the original install method was lag bolted into the transom. The original lag bolts have obviously been removed so I'm wondering if there is still enough "meat" there for another install. Also, I would much rather have a through bolted connection but I know clearances to work are an issue in this area. I was thinking I could make a backing plate out of 1/8" galvanized plate and weld lock nuts onto this plate so essentially the through bolting process would be easier. 

 

Any input is greatly appreciated. Thanks! 

POST NUMEROUS PICTURES OF YOUR DECK, THE POLING PLATFORM, SOME PICS OF IT SITTING ON THE DECK, ETC.

THIS WILL PROVIDE A VISUAL OPPORTUNITY TO COMMENT.

DC

 

Share this post


Link to post
Share on other sites
On 9/22/2017 at 3:06 PM, Wanaflatsfish said:

POST NUMEROUS PICTURES OF YOUR DECK, THE POLING PLATFORM, SOME PICS OF IT SITTING ON THE DECK, ETC.

THIS WILL PROVIDE A VISUAL OPPORTUNITY TO COMMENT.

DC

 

The poling platform is the factory platform as shown in the attached picture. It goes on a 18 Master Angler. I am curious as to what hardware you guys are using to install the mounts to the transom as well as the mounts that go on the deck. My original platform was removed due to welds breaking. Now that I have the welds fixed I wanted some help on how to re-install. Hope his helps. Thanks guys 

IMG_6768.JPG

Share this post


Link to post
Share on other sites

I would thru bolt as much as possible, I think you can get to the back of most of them. Use a good sealant. Probably 3/8 bolts on the transom, and 1/4 bolts on the deck.

Share this post


Link to post
Share on other sites

if like the RF, very difficult to thru bolt.  Upsize the lag bolts (in fact I drilled and added 2 more in the transom plates).. fill with 4200.     When we removed to modify the guy that put back on used the old lags.. it was super wobbly!   So that's when we fixed with thicker lags and 4200.

Share this post


Link to post
Share on other sites

I'm not so sure you'll be able to get to all of them. If you can find matching bolt heads, thru bolt the ones you can get to and use larger lags for the others. Or just go with all larger lags. Use 4200 for sealant, not 5200. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×