Jump to content
Tall Tails

2500/2600 livewell clogging question

Recommended Posts

I have checked the drain lines and they flow freely, I guess I need to double check my modifications and make sure my holes are large enough to accommodate the flow of water. Thanks for your suggestions.

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, RCW said:

I have checked the drain lines and they flow freely, I guess I need to double check my modifications and make sure my holes are large enough to accommodate the flow of water. Thanks for your suggestions.

If I can help more shoot me a text bud 

239-290-0811 we will get it figured out 

Share this post


Link to post
Share on other sites

I have been using the Clearview for five years. It is Awesome and easy. I will not have a bait well without one.  Cam Watts is great to deal with. This is his ideal and for money its is not worth messing with myself, IMO.  The Clearview filter has also allowed me to increase the water level in my bait well. 

Share this post


Link to post
Share on other sites
On 7/8/2019 at 9:09 AM, RCW said:

I used Jay's method and I still had my live well clog on me all day. I will admit I had way too many baits in it but it still clogged even after I removed the excess. Are you using the clear plexi panel with the sleeve?

Did you also have a problem with the live wells overflowing into the boat? We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Share this post


Link to post
Share on other sites
On 7/14/2019 at 8:52 PM, Chitwood21MA said:

Well, I clogged up the livewell today on the 2500 lol

IMG_20190714_113610.jpg

Did you also have a problem with the live wells overflowing into the boat? We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Share this post


Link to post
Share on other sites
On 8/23/2017 at 4:30 PM, Tall Tails said:

I made the sleeve last night. It worked well today but I did not have a ton of bait in there. Spent most of yesterday shoulder deep in the live well trying in vain to keep it from over flowing. I had no issues today but want to make the holes in the sleeve a bit bigger and probably add more holes. Skip assures me that they are working this issue now and will have a fix going forward. If the sleeve works this well perhaps it should be part of the live well from the start. :)

Did you also have a problem with the live wells overflowing into the boat? We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Share this post


Link to post
Share on other sites
On 11/7/2017 at 4:14 PM, RCW said:

Hey Skip

 

Any progress on this issue yet?

 

Thanks

Did you also have a problem with the live wells overflowing into the boat? We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Share this post


Link to post
Share on other sites
On 7/9/2019 at 7:47 AM, Stricklyoutdoors said:

I just screw in the pipe no plexi, I’m not sure how it’s clogging still, might want to check and make sure your drain lines are not clogged up and flowing freely.  I can seriously put a plastic bag inside my well and it won’t clog it up... 

Did you also have a problem with the live wells overflowing into the boat? We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Share this post


Link to post
Share on other sites
On 8/16/2017 at 8:16 AM, imsnookyrd said:

http://clearviewbaitwellfilters.com/

I remember this from several years ago, you might try it.

We have the same problem with the live wells overflowing into the boat. We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Share this post


Link to post
Share on other sites
20 hours ago, Maria De Los Santos said:

Did you also have a problem with the live wells overflowing into the boat? We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Oh god yes. It overflowed constantly. As a guide I was spending most of my time shoulder deep in the well trying to shoo bait away from the standpipe and trying to put that useless piece of plexiglass back in place. Go to Lowes or HD and get a piece of PVC pipe. There are plenty of photos in this thread as to how to create a sleeve for the standpipe. That is the best fix there is. It works most of the time. Put enough grass, jellyfish and other junk in there with the bait and it will eventually clog. Just wrap your hand around the PVC pipe  at the bottom, slide it to the top and throw all the junk away. A couple times of that and its good for the day. 

Share this post


Link to post
Share on other sites
On 10/16/2019 at 10:14 PM, Maria De Los Santos said:

Did you also have a problem with the live wells overflowing into the boat? We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Heck yeah. One of the issues is that so much water has to go down that drain pipe that it creates quite a suction. Any bait or debris that gets near the top of the original standpipe will either go through the holes or begin to clog the holes. Once it's clogged the only place the water can go is up and out...onto the deck. The sleeve fix works very well. That's all you really need to do. Perhaps drill one or 2 small holes low on the standpipe if you want. I chose not to do that as I sometimes want to bring a live well full of water home to keep shrimp alive over night. 

Share this post


Link to post
Share on other sites
On 10/16/2019 at 10:12 PM, Maria De Los Santos said:

Did you also have a problem with the live wells overflowing into the boat? We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

No, only when I massively overload *or* dump the net right into the livewell and it gets clogged up with grass.  

Share this post


Link to post
Share on other sites
On 10/16/2019 at 10:17 PM, Maria De Los Santos said:

We have the same problem with the live wells overflowing into the boat. We have had the problem since the very first time we used the live well and it has been back to the dealer and factory and they have done nothing about it. 

Yes, I modified the original stand pipe like many. It worked but I bought the clear view stand pipe and have zero issues, now.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...