Jump to content

Recommended Posts

2008 22 foot Pathfinder has a floor mounted cast net locker in front of the ice chest forward of the center console.  The drain has stopped up and I have tried water jets, a plunger, coat hanger, all to avail.  I suspect it drains to the bilge, but really don't know.  Any suggestions?

Share this post


Link to post
Share on other sites

Mine also drains to the bilge. You might need to buy an electricians snake. They are pretty cheap and can be used in the future to pull wire. After you get it snaked out, you might want to install a flat strainer to keep big stuff out of the drain.

Share this post


Link to post
Share on other sites

Sorry.   Did not know there were protocols for this site.  Thanks for the suggestion.   Have not tried it yet.   Will advise on the results when I do. 

Share this post


Link to post
Share on other sites

Long story, but here goes.  After trying many options, and having my mechanic try as well, a marina figured it.  The gas tank had been installed improperly.  Apparently, it is mounted on two rails, using something like double sided tape.  The installer did not pull the backing off one of the tapes and the tank was just sitting on the rail.  Over time, it slipped off and somehow blocked the drain line from the net locker.  I now have a repaired hole in my deck below the cooler behind the center console, and a new tank.  But the net locker drains like a new one.  I hope this was a one of a kind error by Pathfinder/Maverick and does not happen to anyone else.  It was a fluke that we found the problem, and an expensive one at that.

Share this post


Link to post
Share on other sites
40 minutes ago, gatrpe said:

Long story, but here goes.  After trying many options, and having my mechanic try as well, a marina figured it.  The gas tank had been installed improperly.  Apparently, it is mounted on two rails, using something like double sided tape.  The installer did not pull the backing off one of the tapes and the tank was just sitting on the rail.  Over time, it slipped off and somehow blocked the drain line from the net locker.  I now have a repaired hole in my deck below the cooler behind the center console, and a new tank.  But the net locker drains like a new one.  I hope this was a one of a kind error by Pathfinder/Maverick and does not happen to anyone else.  It was a fluke that we found the problem, and an expensive one at that.

jeez-----that ***.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×