Jump to content

Search the Community

Showing results for tags '97 hewes light tackle 20'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • GENERAL DISCUSSION
    • General Forum
    • Favorite Topics
    • Photo Zone
    • Tournaments & Funaments
  • OWNER'S DOCK
    • Maverick
    • Hewes
    • Pathfinder
    • Cobia
  • FISHING
    • Florida - Keys
    • Florida - Flamingo & Everglades National Park
    • Florida - Southeast
    • Florida - East Central
    • Florida - Northeast
    • Florida - Southwest
    • Florida - West Central
    • Florida - Northwest & Panhandle
    • Texas & Gulf Coast
    • South Atlantic
    • Mid-Atlantic
    • New England
    • Australia
    • Other Areas
    • Fly Fishing
  • CLASSIFIEDS
    • Boats For Sale
    • Boat Accessories & Props
    • Electronics
    • Tackle & Other

Calendars

  • Community Calendar

Group


Gender


Bio


Homepage


Occupation


Interests


Location


ICQ


Yahoo


AOL


MSN


Full Name

Found 1 result

  1. 97 yamaha Pro V 150 overheat issue

    Lately I ‘ve been getting the overheat alarm and then Limp mode only at high RPM, like close to WOT. If I shut it down, wait 30 seconds and turn the key on, the alarm goes off and I can run all day under 4500 rpm. I started out by changing thermostats, checking the poppet valve (old style) and cleaning it. No change. Recently put a new water pump in. No change. Checked both thermo switches per the repair manual. They are both good. Pulled the heads and checked all water jackets. Some minor blocked areas but have always flushed with ears with fresh water after running in salt. Heads looked pretty good. Cleaned everything up and installed new head gaskets. I also installed the new mushroom style poppet valve. I’m hoping I finLly got this solved but cold and rainy here so no trial run yet. Had anyone had a similar problem? Could it be the poppet valve? I swear the old one looked fine. Thanks. PS this engine has 588 hrs on it
×